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Legacy and DNA 
Notes by Cathy Pinner, July 2022 

Legacy is a feature rich genealogy database. You can use the information you’ve stored in it to help 

identify your DNA matches, keep track of some of the data and use that data for analysis. 

These notes outline some of the ways Legacy can be used as you work with your DNA matches. They 

do not cover how to view and analyse your DNA matches. Note there are many webinars to teach you 

how to use your DNA results.  

The focus is on Autosomal DNA – the test offered by Ancestry, My Heritage, 23andMe, etc. 

Legacy has reports and other features to help identify your matches. 
There are various methods people use to identify unknown matches. Some are more useful than 

others. In my experience, some are better used as a secondary method rather than primary. 

1. Surnames Summary Report 
DNA beginners often look first for known surnames in their DNA match list. For various reasons this is 

not the best starting point. Unless you are looking at close matches or have a very broad and deep 

tree and memory for the surnames you’ve entered, you’re unlikely to find many.  

However, a good knowledge of your most frequent surnames can help, especially when reviewing the 

trees of matches. 

The Surname Summary Report can give you the list of surnames in your Legacy Family File and the 

frequency with which they occur. 

It’s a report that can be saved to CSV file and opened in a Spreadsheet where you can sort on 

Frequency rather than the alpha sort. It includes the Date Range for each surname. 

If you have an extensive tree that includes in-law lines etc etc, to get a useful Surname Summary 

Report you need to tag the relevant part of your tree and export to a new Legacy file and create your 

report from that (temporary) file.  

The easiest way to do this is to Set Relationships to the DNA test taker and then use Search > Detailed 

Search with one condition. 

Individual > Relationship > Equal to > Related 

Tag the Search list by clicking the Options button and then Advanced Tagging. 

Export that tagged group. 

Note when exporting to a new Legacy file, the first step is to provide a filename for the new file. Your 

exported individuals are imported into this new file. This is the opposite to exporting to a Gedcom 

where the final step is to provide a filename for your Gedcom. 

When you’ve finished using this new temporary file, use File > Delete File when it is open to remove it. 

2. Relationship Report 
DNA Match lists include a suggested relationship or range of relationships. Usually you can click 

through for a more extensive list or use https://dnapainter.com/tools/sharedcmv4   

This gives a more visual view of possible relationships for a particular sized match. It also tells you how 

far back you may need to research to find the Most Recent Common Ancestor (MRCA). 

So if the match is likely a 2nd cousin, it makes sense to check whether you have a likely second cousin 

already in your database or can see where further research on your tree would be useful. eg the DNA 

https://dnapainter.com/tools/sharedcmv4
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match name may be the married name of someone already in your database but you haven’t entered 

their marriage. 

The Report is found at Reports > Other Reports > Relationship Report. Obviously you need to set 

relationships to the relevant DNA tester before running it. It can further be limited by tag. 

This report can be saved to a CSV file, opened in a spreadsheet and then sorted by relationship. 

It’s most useful for matches above 330 cM where the MRCA is 2nd great grandparents or closer. It’s 

probably still useful down to about 135 cM. Below 135 cM, the MRCA could be 4th great grandparents 

or closer and rapidly gets more distant. I don't know about you, but my ancestor chart isn’t very 

complete for 4th great grandparents though is almost complete for 3rd great grandparents. This doesn’t 

mean that smaller matches don’t have a more recent common ancestor. 3rd cousins share between 0 

cM and 234 cM. It’s just that the possible relationships balloon out. 

3. Expand the relevant part of your tree in Legacy. 
Shared Matches are a major key to identifying an Unknown DNA Match. They show you which part of 

your tree you will probably find the connection. After working carefully up your tree, to use DNA 

effectively you need to work out and down the sibling lines. 

4. Build trees for your DNA matches 
Legacy is designed for building trees. One of the best ways to identify matches is to build out the tree 

of your match. You only need a starting point which even a tree of 2 people sometimes gives. Since 

many DNA testers are also beginners in genealogy, it’s worth taking the time to start from them and 

verify their tree even if they have several generations of direct ancestors.  

Add the DNA tester as an Unlinked person in your family file. You can build Quick trees on Ancestry 

using tree hints. Preferably you mark the tree as Private AND Unsearchable. For a significant sized DNA 

match I prefer to build them in Legacy or in Legacy as well. There’s a reasonable chance you are going 

to find the connection. If you build in Ancestry by adding people quickly from other trees etc and then 

download a Gedcom, you get a lot of badly entered data (eg locations) and dubious sourcing. I find it 

just as quick to enter directly into Legacy using my location standards etc.  

Sourcing a “quick tree”. I do have a Quick Tree source where I put the URL for the Tree Profile I may 

initially use or the URL or copy and paste of transcripts for historical records when I’m not wanting to 

stop and source correctly. It’s fatal however to enter data with no source at all. It takes so much more 

time to re-find that data source. However, if you already have the relevant Master Source, it’s just as 

quick in the long run to source it properly as you go. 

Note often there is an unidentified living parent and grandparent in a DNA match tree before you see 

deceased people you can identify. In these cases, add Placeholder people in Legacy. You can usually 

work out the surname. If not use Privacy brackets around a possible surname or a relationship. eg 

[[match name’s mother]] or just leave it blank. I use Placeholder for the Given Name. If I can’t see the 

gender, I add them as Unknown gender.  

Remember when you connect new people into your tree, you need to use Tools > Set Relationships 

again. Some relationships are partially added ‘on the fly’ but not embedded into your Family File until 

you use Set Relationships. You can see this clearly if you go to the Relationship Calculator. When the 

relationship has been added by Set Relationships you’ll see the base person for relationships on the 

left and the highlighted person when you go to the Relationship Calculator on the right. If the 

relationship was added ‘on the fly’ then the person will show on the left and no-one on the right. 
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5. Create a Gedcom to upload to your test site to easily connect your DNA to a public tree 
Make sure your DNA is connected to a public tree. A private tree is better than no tree but it means 

your DNA matches can’t do some of the work to find the connection. Use Legacy to create a relevant 

tree with the data you are happy to share. I just include basic BMD data with the relevant sources. 

Renew the tree periodically. I upload a new tree every 12-24 months.  

If you are bothered about people who may have linked to your old tree, just include the upload date in 

your tree title and leave the old tree there. Make sure you connect the DNA tests to your new tree. 

Gedcom settings I use: 

a) I upload a tag group rather than my whole family file.  

b) I don’t include living people apart from DNA test takers whose kits I manage. If possible, I add 

them in on the website itself. It’s easier to use the Privacy controls to totally exclude living 

people when creating your gedcom.  

[For a Gedcom for GedMatch where you have to control privacy yourself, import the Gedcom 

created (perhaps with just direct line ancestors and their siblings) into a new Legacy database 

and then add the living people required using Private or Living or their GedMatch alias as their 

name with no other details and then create a new Gedcom.] 

c) Uncheck the option on the second Gedcom export tab to Override Source options. I have a 

number of sources marked to be excluded from reports and, when checked, this overrides those 

settings. It also includes all source notes and comments. 
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d) I only include the basic BMD data with sources. 

To do this : 

Choose Basic in the Produce file for box – this is just the vital event data 

Click the Customise button if you want to include Sources.  

To the Basic set of tags being exported, you need to add back in the Source data using the 

SOUR and PAGE tags. In the pic I’ve already said to include SOUR and it’s set so I just need to 

click the Include button to move PAGE to the Export these items list 
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6. Use To-Dos to keep track of your correspondence with matches. 
Note Correspondence is one of the three Types of To-Do you can specify. Also, you may want to add a 

Category for this type of Correspondence or just a DNA category for To-Dos you add related to DNA. 

.. 

Ideally record all correspondence in the To-Do with date either of you wrote, the method and the 

important content. I tend to use Task Description rather than Results as it’s more visible.  

If you used email, also add the email address to their mailing address (the house icon on Family View 

and Individual View). I include the date in one of the unused fields. 

To-Dos are most useful if you learn about the various filtering options and sorting options for the To-

Do Report. 

Note there is also a To-Do clipboard you can use to copy and paste a To-Do from one person to 

another. 
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A WAY OF RECORDING AUTOSOMAL DNA MATCHES IN LEGACY 
Use Hashtags and Events to record and analyse your DNA matches.  

How you do this will depend on your aims. 

I have slightly refined what I’ve been doing for several years now. My aim is to verify my direct 

ancestors and, if possible, find missing ancestors. I have a 2nd and a 3rd great grandfather whose 

fathers I don’t know. If your aim is to find a birth parent, your data entry may be a little different and 

include more Shared Events between test takers. 

I have developed a reference group of DNA matches made up of tests I manage or have access to and, 

for matches on sites like MyHeritage that show the amount of DNA the match shares with the Shared 

Match, a few other significant matches. 

I make no attempt to recreate what the testing sites themselves or other software does better.  

eg: It would be possible to use Shared Events to link Shared Matches in the family file and create a 

web. I don’t. At most I highlight a significant Shared Match not in my reference group in the Event 

notes. This is something that would require even more maintenance to keep up to date and I think is 

far more efficiently done by the Shared Match lists at the various sites and tools like DNA Painter. 

For sites with segment data, I put that data into DNA Painter maps and use the maps when analysing. 

These, or parts of them, can be linked to Legacy either by using the Share feature URL or downloading 

or taking a screenshot of the relevant part and linking that image.   

This is quite a lot of data entry but I’ve found it worthwhile with the possible exception of sharing the 

event with the MRCA. 

1) Add Hashtags to a DNA match.  
I add “DNA-Test” to everyone who has done one and then “DNA-Anc”, “DNA-MH” etc to 

indicate which site(s) they are on. If I know a relative has done a DNA test but has no match to 

me or my reference group, I add a different hashtag, “DNA-Tester”. If I don’t personally have a 

DNA match but at least one of my reference group does, I add “DNA-not CJP” (my initials). So 

far 60 out of the 420 DNA matches recorded in my Legacy Family File have this hashtag. 

2) Add the Username to AKA and Name Suffix field 
This is to facilitate finding the match in the Index or in your DNA match list. I add the names in 

Privacy brackets eg [[geneakit]] so they don’t mess up other reports. 

3) DNA Match event.  
This is to record match data. 

a. Click the Edit Event Sentence Definition button and uncheck the Place field and make 

the event a Private event. This way it isn’t included in your normal reports. However, if 

you do want to include it you can always change this setting. You could alternatively 

override Private events in Report Privacy Options. Since I use Private Events for other 

things as well, I wouldn’t unless the report was strictly just for me. 

b. I use the Description field for the MRCA and now add at least the beginning of the 

path down to the tester. 

c. I use the Date field for the last date I updated the information. That way I can see at a 

glance whether I’ve checked for a match and added data for the most recent cousin to 

share data with me.   

d. In Event Notes I add: 

i. The Website and the exact username being used on that site 
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ii. The cM match to myself and to siblings, first cousins and others in my 

reference group of known DNA matches. 

NOTE it is at this point that I check whether the size of the match falls in the 

range for the relationship I have. If it is at an extreme for my whole reference 

group, I’ll make a note and investigate whether I’ve made a mistake in where 

that DNA test taker is linked in my tree. If it is at an extreme for just one or 

two of my reference group but normal for others, I don’t. 

iii. At the top of the Event Note I put anything that is unusual or any interesting 

Shared Match.  

eg: I have match to a fifth cousin on Ancestry and MyHeritage. We share 

about 10 cM. My brother shares 16 cM. However, one of our 2nd cousins 

shares over 20 cM as he’s in the Ancestry Shared Match list. This increases my 

confidence that the match is real and on the projected line. With just my own 

10 cM match I’d be dubious. However, it’s still possible that the DNA comes 

from a different line despite the paper trail for this line as the other lines of 

the match haven’t been investigated. However since they’ve been on different 

continents for about 180 years I suspect this is unlikely. 

iv. A copy of any useful correspondence (ideally this is also in a To-Do). 

v. URL of the DNA Match and/or their tree and/or their profile (especially for 

Ancestry). 

vi. Notes and links to any other place you keep relevant research – eg Evernote. 

e. I have begun to Share the Match with the MRCA. This makes the data more visible for 

step 4 and perhaps lessens the need for searching using the various hashtags I’ve set.  

I’m not sure that I like it. It’s OK if there aren’t many matches with that MRCA but 

where there are lots, it fills up the Event list too much.  

4) Add hashtags for the line to the MRCA.  
a. Use the Relationship Calculator to Tag the line between the Match and one or more of 

my reference group. (Options > Tag relationship line)  

This is most easily done, if this is a newly added person, if you have used Tools > Set 

Relationships before going to the Relationship Calculator 

When you go to the Relationship Calculator, if the relationship has been added by Set 

Relationships, you’ll see the base person for relationships on the left and the 

highlighted person on the right. If the relationship was added ‘on the fly’ or no 

relationship is showing at all on Family View, then the person will show on the left and 

no-one on the right. (image on next page)
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b. Convert the Tag to a Hashtag indicating the MRCA by going to the Name List and using 

Search > Show all tagged #, the Options > Add hashtag to everyone in List. 

I name the hashtags MRCA-surname1-surname2 eg MRCA-COOPER-COLLIS or MRCA-

name only eg MRCA-Elizabeth COLLIS only.  

Don’t forget to then clear the tag so it can be used again for something else. 

5) DNA Evidence Event 
a. These events are added to direct line ancestors.  

b. On the Edit Event Definition screen I remove the Place field, mark the Event as Private 

AND exclude from Potential Problems Report as the dates will all be after the person’s 

death.  

c. The Event Description has a comment on the strength of the evidence that validates 

the relationship. 

d. The Event Date is the Date I last made an analysis. 

e. The Event Notes show the matches through each child of the ancestor. 

f. The Event may be shared with particularly significant test takers outside my reference 

group. 

g. The media may include an image of the DNA Painter map relevant to this ancestor. 

6) Use the Ancestral File Number box for a summary of your DNA Evidence 
eg DNA-verified, DNA-evidence, DNA-? for if you have a paper trail with a DNA match but can’t 

be sure the DNA came via that line or for small matches where the segment may be a false 

segment.  
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Now you’ve entered the data for your DNA matches, what now? 
1) Search for relevant groups of DNA matches using your hashtags.  

eg - Because of the way I’ve added hashtags I can search for DNA testers who share common 

ancestors for whom there is segment data on MyHeritage. 

 

 
 

This type of search is necessary to collect the data for the DNA Evidence event if you don’t 

Share the DNA match event with the MRCA. 

2) Create charts like the Ancestry ThruLine charts.  
You can use the MRCA hashtags to identify and tag relevant lines to export to a new (temporary) 

Legacy family file to create these selective descendant charts. For this, don’t add in the secondary 

checkboxes when exporting a tag group. This is much quicker than marking people as Invisible in 

order to omit a line from a chart and then changing their Private Setting back to Normal.  

Here’s an example with some names blocked for Privacy. The coloured boxes are the DNA 

matches with this MRCA or closer.  It’s showing only a fraction of the descendants entered in 

Legacy.

 

3) Create Legacy Charting Fan Charts which include the “AFN” 
If you’ve used the Ancestral File Number box for your summary of DNA Evidence, this “number” 

can be included in Legacy Charting charts with no label or your customised label. 

eg Fan Charts – This gives you a visual way of keeping track of your progress in verifying ancestors.  
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I periodically save a Fan Chart as a jpg and then use a Graphics Editor to flood fill the segments of 

the Fan Chart according to the amount of evidence. 

Here is a comparison of two charts for my maternal lines. 

 

4) Develop sets of Family View labels to highlight the data you need when working with 

DNA.  
For how to do this see: https://news.legacyfamilytree.com/legacy_news/2019/12/tuesdays-tip-

customize-the-family-view-beginner.html 

Note you can combine Birth/Baptism field and Death/Burial field to free up 3 labels. Or you may 

omit the Death/Burial line and have 4 lines for DNA specific events, hashtags, privacy, AFN number 

if you’ve used it, … 

5) Add Columns for Hashtags to Index View and Descendant View. 

6) Check Privacy Settings 
Depending on how you share your Legacy data, you may want to make DNA testers, particularly 

those who are distant cousins, Invisible as well as their parents. Or it may be enough for you to 

leave out the living when creating Gedcoms for online trees or reports for a distant relative.  

https://news.legacyfamilytree.com/legacy_news/2019/12/tuesdays-tip-customize-the-family-view-beginner.html
https://news.legacyfamilytree.com/legacy_news/2019/12/tuesdays-tip-customize-the-family-view-beginner.html

